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PRELUDE 
Instant Music is for the musician in us all. If you flnd yourself ~ 
strumming air during your favorite guitar riff, or drumming along on 
your car steering wheel, but the only real musical instrument you 
can play is your stereo, then Instant Music may be just what you've been waiting for. 

) 
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Imagine yourself playing the lead guitar solo to your favorite rune, without making mistakes! With Instant Music you don't 
need to know the rules of harmony, counterpoint, or rhythm, to jam impressively. Instant Music lets loose your creativity 
by keeping track of the rules for you. You can give yourself over to the rune that plays in your head. !f you're close,lnstant 
Music will put you right on. 

Butlnstant Music gives you a lot more than just jamming. You can write a full score for a set of four instruments (which you 
choose from dozens), and the artiflcial intelligence built into Instant Music makes sure they play in tune. Or you can use one 
of the many songs on the program disk as a template and add the notes, embellishments, and reflnements yourself. The 
templates have been constructed with the musical information already built in - rhythm, scale, and chord rules. With Instant 
Music you can concentrate on what sounds good, rather than "How do I voice a C9 chord with an E bass?" 

!f you're an accomplished musician, you'll find that Instant Music is a powerful composing tool. It's a great place to sketch 
your ideas with the help of the builtin artificial intelligence. You'll be thrilled at the speed with which you can create different 
arrangements, qwcldy flnding the one combination of voicing and instruments that captures the essence of a song. And you 
can save your ideas to revisit later, when you feel more like ruming off the guides and [me tuning your piece in "free mode" 
to add some unorthodox flair. Later you might move your music into programs like Deluxe Music Construction Set to convert 
it to srandard musical notation and print out a hard copy for the band to play. 

In short,Instant Music is a powerful tool, and it 's fun to use at the same time. You'll create, hear, and see your music insrantly. 
The notes for each instrument are a different color, and the period each note plays is drawn as actual length on the screen, 
so you can easily see the relationships of instruments, rhythms, and pitches. If you're a musician, looking at an entire 16 or 
32-measure song in a single screen will give you a new awareness of music strucrure, and a new way to analyze it. !fyou' re 
a beginner, you'll be amazed at how much you can learn about music, without studying - it's all play! 

How To Use This Manual 
This manual is organized so you can use just as much of itas you want If you like to experiment (and we hope you do), you' ll 
probably want to know how to start the program, load asong, andjam. From there you can play with the controls and discover 
the fun and power of Instant Music on your own. But if you want some specific information, the manual is designed to give 
you that, too. 

The first chapter, Guided Tour, is an overview of the program that gets you up and running fast, demonstrating why we call 
the program Instant Music. The second chapter, Going Further With Insrant Music, is a series of lessons that illustrate the 
program's more advanced features for those who want to create their own complex compositions. The third chapter, Insrant 
Music Reference, is a quick reference gwde listing all of! nstant Music's menus and commands. The appendix at the end of 
the manual contains documentation for the music included with Instant Music, and information for those who want to learn 
more about music theory and notation. 
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CHAPTER 1: GUIDED TOUR 

Starting Instant Music 
To usel nstant Music you will need an Apple lIeS, a monitor, one or two disk drives, and some initialized blank disks for saving 
your work. Instant Music requires 5l2K of RAM when starting your system with the program disk. (Note: if you connect 
speakers or headphones to your computer the sound quality will be greatly improved.) 

Start your Apple lIes as usual. The flISt thing you should do is to make a working copy of your Instant Music disk to reduce 
the chance of anything happening to the original. (If you have questions about how to initialize disks, copy disks, delete files, 
and move files from one disk to another, consult your lIeS documentation before going any further.) Note: you can name 
your backup disk anything other than 1M; that name is reserved for the master key disk only. 

Now reboot your Apple lIeS with the working copy of Instant Music. Whenever you start Instant Music from the working 
copy, you are asked to briefly insen thel nstant Music key disk so the program can read the disk's registration numbers. When 
the original disk has been verified, you can put it away, and use the copy during the rest of your session. After the program 
has fmished loading, the title screen appears, followed in a few moments by thel nstant Music screen. The Instant Music theme 
song is loaded automatically and begins playing. 

Before we start on our guided tour, let's take a quick detour and become acquainted with Mousejamming, a technique for 
turning your computer into a realtime musical instrument Notice the button in the upper-right comer of the screen that 
contains a white icon in the shape of the mouse. This is the Mousejam Button; the white icon indicates that mousejam is 
currently on. Now take a look at the instrument controls at the very bottom of the screen. The instrument name in the control 
at the far left is shown in white letters; this means that that instrument is currently chosen for you to mousejam with. Move 
the mouse pointer so it's in the large center window that contains the colored bars, hold down the mouse button, and start 
moving the mouse forward and backward. You')) hear that the selected instrument is now playing in response to your mouse 
movements. How's that for an example of instant music? 

We')) discuss mousejamming in more detail in the Mousejamming section later on. For right now ,let's begin with some other 
basics you')) need to know while working with Instant Music. 

The Help Line 
You can operate I nstant Music through a number of differentonscreen controls. If you are unsure of a control's purpose, press 
and hold the mouse button on the control in question. As you press each control, a brief description of its function appears 
on the Help Line at the very top of the work screen. For now, click each of the controls with the mouse button and watch 
the line at the top of the screen. 

Now click the White Button in the upper-right comer of the work screen to stop the music. Also click the Mousejam Button; 
when you click the button, the mouse icon turns black, indicating that the feature has been turned off. 

Loading Music 
To load a song from the Instant Music disk, move the mouse pointer to the top of the screen and press the mouse button. This 
makes thelnstant Music menus appear. While holding the mouse button down, pull down the File menu, highlight the Load 
option, and release the button. A dialog box appears (see Fig 1.1) asking for the name of the song you want to open. Click 
the scroll bar on the right side of the dialog box until you see the folder named Rock!. (If you are unfamiliar with terms such 
as "scroll bar" and "dialog box," consult your lIes documentation.) Click Rockl with the mouse button, and then click the 
Open button (or simply double-clickRockl); the program automatically opens that folder and displays its contents. Nowclick 
the song title Hey You; then click the Open button to load the song (or double-click the song title). 

The song is now loaded, complete with notes, instruments, volume and tempo settings, and pitch and rhythm guides. (pitch 
guides restrict the pitch of notes you can enter in a song to ensure that your song sounds "good." Rhythm guides set the length 
of notes you can enter. You '11 learn more about these guides in Chapter 2.) 

NOTE: Use Load New in the File menu to load the blank template for a song. This loads every component of the song except 
the notes - the instruments, the volume and tempo settings, and the pitch and rhythm guides. You can then enter your own 
notes. 



Now that you know how to load a song and how to use the Help Line, you might want to experiment with the controls and 
menus. When you're finished experimenting, or if you run into trouble,just come back to this point in the manual and reload 
Hey You as explained above. The following few pages explain the features of Inslanl Music that you are likely to use most 
often. 

Playing Music 

Load Song 
-8l I' 1m I'Musicl' 
D Classical m 
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D Progressions 
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Figure 1.1: The Load Song Dialog Box 
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As soon as the song has finished loading from the disk (when the drive light has gone out), click the red Play/Stop button 
at the top right of the screen. Now the button changes back to white, and Hey You begins playing. You stop the music by 
cliclcing the Play/Stop button again. For now,let the song play. 

The Instant Music Screen 
Let's take a closer look at the I nslanl Music screen. What you see is a two· measure overview of the song in the Score Window 
in the center of the screen, and a number of surrounding buttons and controls (see Fig 1.2). The conttols at the top of the screen 
let you work with the entire song· for example, to speed up the tempo. The Scroll Bar (with left and right arrows) lets you 
scroll left or right through a song, one measure at a time. We'll discuss the function of the other buttons, bars, and icons at 
the lOp of the screen as we go along. 

The moving line below the score window is the Rhythm Line and shows what portion of the music is currently playing, and 
the pauern of the current rhythm guide. (The pattern is visible only when three or fewer measures are displayed in the score 
window.) Below the Rhythm Line are the controls for the four instruments playing in this piece (called Track Controls). 
Each track control contains a CurrentInstrument Name, Transposition Buttons, a Volume Bar, and a Hide/Display Button. 
The term Irack, as used in Inslanl Music, refers to a set of notes (indicated by color) and the rhythm guides, pitch guides, and 
instrument assigned to that set of notes. Just as in music recording, you can manipUlate the sound of each track separately, 
before combining them into a finished song. When you copy notes from one track to another, you are actually copying more 
than just notes. This will become clearer as you begin to use the editing functions. 

Figure 1.2: The Inslanl Music Screen 
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Changing Tempo 
Move the cursor arrow up to the white horizontal Tempo Bar at the upper left comer of the screen. Click with the mouse 
button, and drag the marker to the left to slow down the music. Drag to the right to speed it up. 

Changing Volume 
You can control the volume of each of the four instrumental voices using the Volume Bars in the instrument controls below 
the score window. Click on the right side of the Volume Bar in the green track control (the green horizontal bar) and drag 
it slowly to the left. As you do so, note that the volume of the instrument decreases and the green notes on the screen grow 
dimmer, giving you visual as well as auclitory feedback. As you move the Volume Bar back to the right, the instrument 
becomes louder, and the notes grow bright again. 

Viewing Tracks 
You can make the notesclisappearentirely by clicking the HidelDisplay Button to the right of the Volume Bar. Click it again 
to make them reappear. This doesn ' t affect the sound of the piece, only the appearance. Sometimes when there are a lot of 
notes on the screen, you may want to look at the notes of just one track. Switching off the notes of the other tracks is a quick 

way to get an overview of a single melody line. 

Transposing 
With Jnstanl Music, you can raise or lower a track's pitch (transpose) by an octave without changing the key. Use the 
Transposition Buttons (the down-arrow, the square, and the up-arrow at the bottom left of each track control.) When the 
middle square is lit, the track plays at its normal pitch. If you click the down-arrow, the track plays an octave lower. If you 
click the up-arrow, the track plays an octave higher. Clicking clifferent Transposition Buttons does not, however, change 
the note clisplay in the score window. 

Changing Instruments 
The Sounds n:enu contains the list of the instruments currently available for use in a song. (Pull down the Sounds menu to 
see your current list.) If you want to use a clifferent instrument in the green track, just click the name of the green instrument 
in the control at the bottom of the screen. Now pull down the Sounds menu and select your new instrument Your new 
instrument is loaded as the green instrument, and its narne now appears on the green track control. 

The Sounds Menu section of Chapter 3 explains how you can add and remove instruments from the menu. 

If the Sounds Menu is Full 
If you try to load a song and the Sounds Menu is too full to store all the song's instruments,lnstant Music tells you to delete 
some instruments. (Use Purge Instruments in the Sounds Menu, described in Chapter 3.) Then load your song again. All 
the instruments for your song will now be added to the Sounds menu. 

Entering Music 
You can enter new notes, or change existing notes for any of the four instrument colors. First, make sure Mousejarn is off, 
and then select the instrument you want to work with by clicking its track control (select the red instrument for this exercise). 
Now move the mouse pointer into the score window: Notiee that the flashing white cursor appears right next to the mouse 
pointer. Use the mouse to move the flashing cursor around the window; at the same time, click the mouse button in the score 
window a few times. If you click the mouse button on a blank column in the score, a new note is insened at the flashing cursor 
position. If you click in a column that already contains a note for your instrument, the note is raised or lowered to the flashing 
cursor position. 

The color of two notes that occupy the same spaee in the score window will appear gray. The clisplay color of three or more 
notes placed on top of each other is unpreclictable. Click the HidelDisplay Buttons on the instrument controls to view each 
note's true color in turn. 

To erase an existing note, point to the note with the flashing cursor; then hold down the Command key at the bottom left of 
the keyboard and click the mouse button. (In this manual, we will refer to this as Command-clicking). 

The QuickDraw Etude in Chapter 2 shows another method of entering music. 



Mousejamming 
Instant Music offers you the unique opportunity to play your computer as though it were a musical instrument. When you 
select a track control and click the Monsejam Button (Figure 1.2),lnstant Music lets you use the mouse to control the 
instrument assigoed to the selected track. Thus, you can jam on a single track while the other three tracks play backup. In 
addition to the Mousejam Button, there is also a Jam menu that provides three different typeS of mouse jam. (Note: When 
you pull down the Jam menu you will see that a keyboard equivalent is offered to save you the time of pulling down menus 
to execute some common commands. Here, for example, you could hold down the command key and press K toselect KeyPad 
Rhythm for jamming.) 

Score Rhythm: The Score Rhythm option keeps your mousejam within the musical boundaries established by the song 
template. In essence, Instant Music looks over your shoulder as you mousejam and makes sure that you don't play any off
key or out-of-time notes. Here's how to playa guided mousejam: 

1. Click the Play/Stop Button to play the song if it's not already playing. 

2. Click on the red track control to select it as the instrument you want to jam with. 

3. It's a good idea to raise the volume of the mousejam instrument and lower the volume of the other three. This 
makes your mousejam solos really stand OUl 

4 . Pull down the Jam menu and select Score Rhythm. 

5. Click the Mousejam Button at the top right of the screen (see Figure 1.2), and suddenly your selected track stops 
playing notes from the score. This is supposed to happen; Instant Music has just turned control of the track's 
instrument over to you. 

6. Now move the pointer down to the score window. The flashing cursor is now moving from left to right in synch 
with the Rhythm Line. 

7. Press the mouse button and your instrument begins playing again. When you release the mouse bunon, your 
instrument stops playing. 

8. Now, while holding the button down, move the mouse up and down. Try moving it slowly, then more quickly. 
The pitch rises when the flashing cursor is at the top of the screen and falls when it's at the bottom. 

9. Click the button several times as you move the mouse. Your mousejam instrument plays an individual note each 
time you click. 

As you can see and hear, the instrument is now playing in response to your mouse movements, but the notes are being kept 
in the proper key and tempo. 

KeyPad Rhythm: The KeyPad Rhythm option lets you use your computer's numeric keypad to activate stored mousejam 
rhythm styles. To get a feel for KeyPadRhythm,select the KeyPad Rhythm option from the Jam menu, start mousejamming, 
then push the 1 key on the numeric keypad. Now try 2, 3, 4, and so on until you've gone through all the preset licks on the 
keypad. KeyPad Rhythm lets you add another dimension of rhythmic flexibility to your mousejams. 

Free Rhythm: The Free Rhythm mode operates exactly like Score Rhythm, except the song template rhythm guides aren't 
used in the mousejam. While this gives you much more control over individual notes in the melodic line, it also allows you 
to play notes when they really shouldn't be played. Other mousejam modes are better for more structured improvisation 
because they use preset rhythms as guides. 

Mousejam Experiments: With Hey You still loaded in the score window, try selecting the bass line (the yellow track, which 
uses a piano as the instrument) and mousejamming with thal Click the down-arrow Transposition Button to turn the blue 
piano track into a second bass line, and listen to the harmonies as you mousejam. What you're doing is like jazz improvisation 

- making up new notes "on the fly" to fit into apre·existing chord structure. Instant Music's guides keep your notes within 
a preset pattern so no matter what you play, the notes fit. If you want to hear a mousejam without pitch guides, select Set 
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Guides from the Draw menu. Click the Free buuon in the Pitch Guide column and click Apply. Then try a mousejam. Now 
your creativity is completely unbridled, because the Free Pitch Guide option removes the guides that keep the pitch of your 
notes within craditional musical boundaries. 

Keyboard Changes: In addition to the numeric keypad, you can also use other keys on the keyboard to make changes as you 
mousejam. 

Finishing a Session 

A 
S 
D 
F 
Spacebar 
i 

Selects the green instrument 
Selects the red instrument 
Selects the blue instrument 
Selects the yellow instrument 
Starts and stops the music 
Raises the pitch for all tracks a half step. Changes the sound, not 
the display. 
Lowers the pitch for aIIlraCks a half step. 
Resets the pitch for all tracks to the normal settings. 

So far, you've been experimenting with existing music. In the next chapter, we'll discover how Instant Music lets you write 
your own compositions, even if you know nothing about musical notation. 

Saving Your Creations 
If you want to save the music with the changes you've made, use one of the options in the File menu - Save or Save As. 

Save: Replaces the original song with your changed song, using the same title. Use this option if you have made modifications 
to a previously saved song and you want to keep the new version but not the original. Pull down the File menu and select 
Save. 

Save As: Lets you save your new song (or your modified old song) under a different title, while retaining the old song under 
the original title. First pull down the File menu and select Save As. When the Save As Dialog Box appears, click a folder 
name, type a new name for your piece in the Save As box, and click Save. The piece will be saved under the new name. (If 
you want to save the file to a different disk, insert your disk and click the Disk button until the appropriate disk name appears. 
Then click the folder name, type the fIle name in the Save As box, and click Save.) Or if you change your mind and decide 
you want to go back to the Instant Music screen without saving, click Cancel. 

Organizing Your Disks 
There isn't room to save other songs on your backup disk along with all the music that comes with/nstant Music, so you may 
want to consider organizing your music on several different backup disks. From the Apple IIGS Desktop, copy the Music 
and Instrument folders onto another disk. Next throwaway all the folders within the Music folder, except Rock I and Rock2. 
Use this disk to do all your rock composing. Now use the same procedure to make another disk for jazz, another for classical, 
and so on. Name each disk accordingly. Create new folders for your own special music on the various disks. Using this 
method to organize your / nstan! Music disks and fIles, you will have enough disk space for about 40 songs, 10 to 30 measures 
in length, on each disk. But remember: the longer the song, the more disk space required. 

Changing the Instant Music Theme Song 
The theme song in the music folder called InstantMusic is automatically loaded and played with mousejam on when you start 
the program. If you delete the Instant Music theme song, the program will start with a blank score window and mousejam 
off. If you want to use another song as the startup music, delete the Instant Music theme song, put the new song in the Music 
folder, and rename it Instant Music. 



CHAPTER 2: GOING FURTHER WITH INSTANT MUSIC 

This section is composed of nine etudes that cover the advanced features of/lIStant Music in detail. An etude (pronounced, 
"ay-too<I") is a simple lesson that introduces a specific technique or method. Each etude is made up of a number of short 
exercises. The foUowing etudes are self-contained and may be referred to individually if you have questions about how to 
accomplish a specific task in IlIStant Music. For instance, if you want to know how to use fllStant Music's rhythm guides, 
see the Rhythm Guide Etude. Some of the etudes require you to save compositions to disk, so you should have some empty 
music folders ready on your backup disk. See Organizing Your Disks in Chapter 1 for an explanation of disk strategies. 

L Edit Commands Etude 
This etude discusses how to copy, paste, and erase measures in your song. (The commands you'll need are found in the Edit 
menu.) You 'Uleam how to change the length of your song and move notes, rhythm guides, and pitch guides within a song. 
The three exercises in this etude illustrate the difference between pasting with pitch guides and without. 

Here is an overview of the commands you 'u use: 

Function 

To copy one or more measures of a song (including 
notes, rhythm guides, and pitch guides) 

To erase one or more measures of notes (but not 
rhythm guides or pitch guides) 

To paste a copy of notes, rhythm guides, and pitch guides 

To paste a copy of notes and rhythm guides (but 
not pitch guides) 

Edit Commands 

Copy Color, Copy All Colors 

Erase Color, Erase All Colors 

Paste Color, Paste AU Colors 

Paste Rhythm, Paste All.Rhythms 

Exercise 1: Lengthening a Song. 10 this exercise you 'Uleam how to copy existing music and add it to your song. 

1. Load Rock8 from the Progressions folder of the fnstant Music program disk. 

2. Select Song Size from the Options menu to add some blank measures to your song. Click the up-arrow (+) until 
the Maximum Length equals 4 and then click Proceed. Notice that four measures are now displayed in the score 
window. The fIrst two measures contain the original Rock8 song, and the next two measures are blank. 

3. Click the Select Button above the score window. Position the mouse pointer in the upper left corner of the score 
window, hold down the mouse button and drag the mouse pointer toward the right to select the fll'St two 
measures, then release the mouse button. 

4. With the ftrst two measures selected, puU down the Edit menu and select Copy AU Colors. (This copies the 
notes, rhythm guides, and pitch guides from those two measures into the copy buffer.) 

5. Now click the Select Button and select measures three and four. 

6. Select Paste All Colors from the Edit menu. This teUS Instant Music to paste the notes, rhythm guides, and 
pitch guides into the score in the measures you selected. You have now lengthened Rock8 to four measures 
without having to enter any notes by hand. 

Exercise 2: Transferring Music Between Tracks. In this exercise you'llleam how to move music from one track to another. 

1. Click the left-hand double-arrows in the Zoom Bar twice to zoom in and show only measures 1 and 2 in the 
score window. 

2. Now select the blue track by clicking its track control. 
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3. Select the entire score window with the Select ButtOD and use Copy Color from the Edit menu. (This copies 
the notes, rhythm guides, and pilCh guides from the blue track only into the copy buffer.) 

4. Click the Select Button and select the entire score window again. Erase tIu! blue track using Erase Color. 

5. Select the green track. 

6. Again, select the entire score window, but this time select Paste Color. The notes, rhythm guides, and pitch 
guides from the copy buffer (which had previously belonged to the blue voice) have now been transferred to 
the green voice. Note that we didn't have to erase the green voice; we simply pasted over it 

Exercise 3: Pasting Notes and Rhythms Only. In this exercise, we'll paste notes and rhythm guides from one part of the 
song to another,. but not pilCh guides. Use this technique to achieve interesting musical effects. 

I. Click the right-hand double arrows in the Zoom Bar twice to show all four measures. 

2. Copy measures 3 and 4 (for all four tracks) with Copy All Colors. 

3. .Click the Select Button. Drag across and select measures 2 and 3. 

4. Now select Paste All Rhythms. This pastes the notes and rhythm guides (but not the pitch guides) from the 
buffer into the selection. The previous pilCh guides in theSe measures are left unchanged. 

II. Rhythm Guides Etude 
This etude explains the concept of rhythm guides and shows you how to use them in creating your own music. The exercises 
in this etude also point out the difference berween the standard rhythm guide (called Guided) and the custom rhythm guides 
available from the Draw menu (such as 114 and 118). 

Exercise 1: Using Standard Rhythm Guides. In this exercise, you'll learn how to copy the standard rhythm guides for a 
song, view these guides for each track, and use them to create your own song. 

1. Load Rockflighl from the Rock2 folder and play it 

2. Select all the notes and erase them using Erase All Colors from the Edit menu. (The notes of your song are 
now erased, but the rhythm guides and the pilCh guides for that song are left unchanged. Each track has its own 
rhythm guide.) 

3. Narrow the score window to three measures with the Zoom Bar. (Now you can see the rhythm guides in the 
Rhythm Line below the score window.) 

4. Pull down the Draw menu and select Set Guides. This displays the Set Guide Dialog Box (see Figure 2.1). In 
the Rhythm Guide column of the dialog box, make sure that the Guided button is selected. Then click Apply . 

. (This tells [nstanl Music to keep the standard rhythm guides for the song.) 

Pitch Guide Rhythm Guide 
o Melod!:l @ Guided @ Discrete 
@Chord 01/'1 0 Multiple 
o Scale 01/'1 Triplet 
o Free 01/8 

01/8 triplet 
«ApplYD 0 1/16 

01/16 triplet 
[Cance 1] 

Figure 2.1: The Set Guide Dialog Box 



5. Now select the four IIacks, one by one; look at the Rhythm Line (below the score window) for each track. 
Notice that the black bars in the Rhythm Line vary in length to reflect the rhythm guide pattern for that track. 
A track's rhythm guide determines the length of the notes to be inserted in that track. 

6. Select a track that has a great deal of rhythmic activity (black bars of many varied lengths), and enter some notes. 
Notice that the lengths of these notes correspond to the lengths of the rhythm guide bars in the Rhythm Line. 

Exercise 2: Using Custom Rhythm Guides. In this exercise, you' ll see how to change the rhythm guides for any of the 
instruments to the custom rhythm guides that can be accessed through the Draw menu. 

1. Pull down the Draw menu. Select Set Guides, and in the Rhythm Guide column, click the 114 button. Make 
sure that the Discrete button is selected. (If it's not, click it to deselect) Click Apply. Now any notes you 
add to the score will automatically be quarter (1/4) notes. (Notice that a grid of dotted vertical lines now appears 
on the score. These are to help you judge the comparative length of notes, especially when you change rhythm 
guides several times and add notes of several different lengths.) 

2. Select a IIack and enter some notes. Notice that the corresponding black bar on the Rhythm Line changes to 
reflect the length of each note you add to the score. 

3. Try other rhythms such as 118, 118 triplet, and 1116; and enter some notes in the score while in each of these 
guides. While in each of these guides, hold down the mouse button and slowly move the cursor across the screen. 
This is an easy way to enter a number of notes in one gesture. 

4. Go back to the Draw menu and choose Set Guides. In the Rhythm Guide column, click the 118 andMuItiple 
buttons. Click Apply. 

5. Enter notes on the screen by slowly dragging the mouse down and to the right. Notice that when using 118 and 
Multiple, notes are entered in lengths that are multiples of 1/8; i.e., 1/8, 1/4, and so on. 

NOTE: If you are familiar with musical notation, you can write rhythms and enter drum patterns or melodies using custom 
rhythms. If you are truly ambitious, try taping one of your favorite drum patterns, then IIaDscribe it into I nstant Music. You'll 
learn about the different percussion instruments comprising the drumkit in the next etude. 

m. Drum Patterns Etude 
This etude works with drum patterns. Here you will learn how to use the drumkit, as well as parts of the scale ruler. 

1. Load PopBOs from the Rockl folder. 

2. Narrow the score window to display only four measures. Select the measures, and use Erase All Colors from 
the Edit menu. 

3. Pull down the Draw menu and select Scale Ruler. A picture of a keyboard and a single letter note indicator 
appear on the left side of the score window. On the right side of the window is the scale ruler. As you move 
the mouse pointer up and down, watch the note indicator on the left side of the window change to show the note 
you are pointing at A dot also appears on the appropriate piano key. (Chapter 3 contains a full explanation 
of the Scale Ruler.) 

4. Now pull down the Draw menu and select Set Guides. In the Pitch Guide column, select Free. Click Apply. 
The scale ruler on the right should be completely blue, signifying a Free Pitch Guide. This means that Instant 
Music wilJ not be controlling your choice of notes. You can play any note on the keyboard, whetherit sounds 
"good" or nOl 

5. Click the yellow IIack control to select the drumkit. Now click the Mousejam Button and then click the Playi 
Stop ButtOD. Place the mousejam pointer at the bottom of the score window and press the mouse button. Notice 
that the dot is on the lowest note of the keyboard (C). Continue to hold the mouse button and slowly move the 
pointer toward the top of the score window. Listen to the drum pattern and you'll notice that, as the mousejam 
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pointer moves through the scale, different drums sound. Notice also that each drum changes pitch as you move 
the mousejam pointer up or down. Each inslIUment in the drumkit has its own range. 

6. To see how different drum patterns are conslruCted, examine the patterns in any of the songs, paying particular 
attention to the songs in the two rock folders. 

This erude has helped point out the various "ranges" in the drumkit which detennine the actual percussion inslIUment that 
sounds. As you gain experience with Instant Music, rmding individual drums on the spur of the moment will become second 
nature. Think in tennsoffouroreight bar segments when composing drum parts. It is sometimes good to add afill right before 
these four and eight bar boundaries. A fill is a dense solo-like drum pattern used to accentuate a strong beal For a hot drum 
lick, tty using the tom-found at the second CoB octave-with 1116 triplet rhythm guides. The drumkit at the end of the 
second measure in FriscoVice (Rockl folder), illustrates this last effect. 

IV. Bass Lirie Etude 
In this etude you'll use the Chord Pitch Guide and the scale ruler to write a simple bass line. 
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1. Load NightLife from the Rock2 folder. Listen carefully to the bass line (Track 3). Tum down the other 
inslIUments if you like. 

2. Pull down the Draw menu and use the Scale Ruler command if the scale ruler isn ' t already displayed. Then, 
set the Pitch Guide to Chord. The chord pitch guide insures that all notes you enter are valid notes that belong 
in the chord. . 

3. Place the mouse pointer in the nrst measure and move it up and down. This causes two other changes on the 
screen: I) A white arrow moves up and down the scale ruler on the right side of the score window, and 2) the 
nOle indicator below the keyboard on the left side of the screen displays the letters of the notes in the scale. Move 
the mouse pointer until the white arrow is aligned with a white tick mark, which represents the root note of the 
chord. The note indicator shows that the root note is E. 

4. You can use this method to detennine the other three notes in this chord, which are G, B,and D. The Help Line 
at the top of the screen describes the chord as E minor 7. 

5. Select the bass voice (Track 3) and choose Erase Color from the Edit menu. 

6. To compose a new bass line, use the Zoom Bar to narrow the score window to display only two measures. The 
two measures of bass line that you build can later be copied and pasted to the rest of the song. 

7 . . Set the Rhythm Guide to 114. Look at how the two measures are now divided in the score window. The solid 
vertical line down the center of the window indicates the measure division, and the dotted vertical lines indicate 
where the beats within the measures fall. You're using 114 rhythm, which means there are four beats per 
measure, thus each measure in the score window is divided by four vertical dotted lines. 

8. Move the mouse pointer until the white arrow on the Scale Ruler is pointing at the second to bottom white tick 
mark and the Note Indicator says E. Click in the nrst and third beats of the nrst measure to insert the note E. 
Because each of these notes is only a 1/4 beat in length, they are called quarter notes. (Note: to erase any 
mistakes, Command-click on the incorrect note.) 

9. In the second measure, which is an A Dominant 7 chorel, enter an A quarter note on the fust and third beats in 
the second lowest octave. 

10. Zoom out to display all eight measures of the song, and Copy Color the two measures you've entered. 

II. Now select measures 3 & 4 of the song and use Paste Color. Repeat this process with measures 5 & 6 and 7 
& 8 so that the fust measures are duplicated throughout the rest of the song. Listen to the song. The result is 
a very plain bass line, so let's add a bit of variety by modifying each measure of the hass line. 



12. Zoom back in to two measwes and lower the second note in the first measure one step from E to D. 

13. Lower the second A note in the second measure by a full octave. 

14. Now Zoom out to display the entire song and copy the fIrst two measwes with Copy Color. 

15. Use Paste Color to duplicate your two measwes throughout the rest of the song. Now listen to the song again . 
You should be able to tell quite a difference from the previous bass line. 

This erude has demonstrated how to display the Chord Pitch Guide, how to create a simple bass line, and how to add variety 
and substance to the bass line just by rearranging notes within the chord. In the next erude, we'll see how to build an actual 
chord. 

V. Chords Etude 
This erude demonstrates how to use Instant Music's polyphonic chord utility. The word polyphonic simply refers to Instant 
Music's ability to sound multiple notes at the same time from a single instrument - an ability that is essential for playing 
chords. (Instant Music on the Apple IIGS can sound 3 notes at the same time for each instrument and can play 4 instruments 
at once. You can play 12 notes at one time if each instrument plays a three note chord.) 

1. Load BamDance from the Folk folder. 

2. Select the piano (blue) track and Erase Color. 

3. Set the Pitch Guide to Chord and the Rhythm Guide to 114. (Also from the Draw menu select Scale Ruler 
if not already selected.) 

4. Zoom in to display only four measwes and begin entering quarter notes on the frrst and third beats in these 
measures. Enter notes on the root of the chord (the white tick mark). Enter the lowest possible root note because 
the notes on beats one and three will fonn the bass line. 

5. You have just entered all the oom' S, but you still need to enter the pah' s. Click on the three black dots of the 
Chord Control (above the score window and to the right of the Select Button) so you can enter 3-note chords. 

6. Now enter chords at mid-screen level on the second and fourth beats in the selected measures. Every time you 
click the mouse button, three notes are entered. These three notes togetherfonn the chord. Chords are builtdown 
from cursor position, so your cursor always points at the top note of the chord. 

7. When you have entered chords in all four measures, play the piece and listen carefully. 

8. Experiment by changing all the 3-note chords to I-note chords (by clicking the single dot on the Chord 
Control), and listen to the difference. 

In this erude you have perfonned an example of entering chords as an accompaniment to a melody. Generally, a good strategy 
is to put chords on the weak beats (2 and 4 in 414 rhythm; 2 and 3 in 3/4 rhythm), and single bass notes on the strong beats 
(1 and 3 in 4/4 rhythm; 1 in 3/4 rhythm). Experiment with using 1, 2, or 3-note chords until you fInd the sound you like. 

VI_ Pitch Guides Etude 
This erude is a continuation of the previous erude (Y. Chords Etude). If you haven't done the chords etude yet, do it before 
continuing with this one. 

The following exercises demonstrate how to incorporate the Melody, Scale, and Free pitch guides in the melody line of your 
composition. Pitch Guides are one of Instant Music's most powerful tools because they restrict the pitch of notes you can 
enter in a song to ensure that your song sounds "good" Each pitch guide restricts you in a different way. The fewerrestrictions 
you have (for example, with the Free pitch guide), the more opportunity you have to cre.ate strange sounds, and the more 
careful you must be when entering notes. 
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Exercise 1: Using the Melody Pitch Guide. In this exercise, you'l\ see how to use the Melody Pitch Guide. 

I. Zoom in 10 display measures I and 2 only. 

2. From the Draw menu, select Set Guides. In the Rhythm Guide column, select the Guided option. In the Pitch 
Guide column, select Melody. Click Apply. Select the green track and note the rhythm guide pattern for the 
green track on the Rhythm Line. 

3. Enter notes for the green track at the lOp of the score window. You'l\ notice that the scale ruler changes as you 
enter notes. The scale ruler changes on each beat 10 reflect the boundaries set by the Melody pitch guide. 

4. When you have entered a simple melody, play it to see how you did, save it if you want, then erase it. 

Exercise 2: Using the Scale Pitch Guide. In this exercise, you'll see how to use the Scale Pitch Guide and how it effects 
your music. 

I. Set the Pitch Guide 10 Scale. 

2. Enter a new melody at the lOp of the score window. Notice that there are many more notes on the scale ruler 
. now, giving you a great deal more freedom in where you can enter notes in the score. 

3. Once again, play your melody. If you notice that your new melody doesn't sound quite as good as the last (this, 
of course, will depend upon your musical knowledge) it's because Instant Music didn't give you as much help 
when placing your notes this time around. Erase your melody again. 

Exercise 3: Using the Free Pitch Guide. In this exercise, you'\I see how to use the Free Pitch Guide and how it affects your 
music. 

I. Set the Pitch G\lide 10 Free. 

2. Now enter another new melody and listen 10 it. With a Free Pitch Guide the sound of your music depends 
. entirely on your musical abilities - Free Pitch Guide gives you absolute freedom in the way you enter notes. 

The last two etudes have covered all four of the Pitch Guides. The Pitch Guide you use most when creating your music will 
depend on your knowledge of music. Novices should always use Melody and Chord. Intermediate musicians should use 
any of the first three Pitch Guides and experiment with Free. Experienced musicians can use whichever Pitch Guide is 
appropriate for the musical project. 

vn. QuickDraw Etude 
This etude introduces another powerful tool of Instant Music: QuickDraw. 

Exercise 1: Using QuickDraw. In this exercise, you'l\ see how to use the QuickDraw function 10 quickly enter large 
numbers of notes inlO your composition. 
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I. Use Load New to load Boogie from the Iazzblues folder. 

2. Zoom in to display only two measures. 

3. Set the Pitch Guide 10 Scale and the Rhythm Guide 10 Guided. QuickDraw can only be used with the Guided 
Rhythm Guide. 

4. Click the QuickDraw Button above the score window. (The lightning bolt turns white when seJected.) 

5. Position the cursoron the left side of the score window, hold down the mouse button, and drag the cursor straight 
across to the right side. As you drag you'l\ notice that a line stretches from the point where you initially pressed 
the mouse button. 



6. Release the mouse button on the right side of the score window and watch I nstant Music fill in notes along the 
path created by the line. TIlls is QuickDraw. Listen to your new creation if you want and then erase. 

Exercise 3: Using QuickDraw Patterns. In this exercise, you'l1learn how to QuickDraw in different patterns that create 
interesting lines of music. 

1. Pull down the Draw menu and select Pattern4. Click the QuickDraw button again. Notes entered with 
QuickDraw will now be entered in the pattern represented by the three dots you selected. 

2. Once again drag a line from the left side of the score window to the right Though the line itself is still straight 
as you drag across the score window, notes are entered in a wavy pattern as you release the mouse bunon. 

3. Play your new QuickDraw creation and listen to the difference with this new panern. 

4. Experiment with the other QuickDraw patterns. 
In this etude you've seen how to use QuickDraw. You can add even more variety to your music by using different Pitch 
Guides with the QuickDrawpatterns. For instance, try using QuickDraw with 3·note chords (see V. Chords Etude). Vary 
the pattern often when you use QuickDraw. An interesting effect is to enter the tremolo panern (pattern2 and Panern3) in 
one track and the triplet pattern (pattern4) in another track. 

VIII. Progressions Etude 
This etude demonstrates how to use progressions from the songs provided with Instant Music in your own compositions. A 
progression is a song segment used over and over in various places throughout a composition - like a repeating chorus. 

1. Load RockS from the Progressions folder. 

2. Select the entire score window with the Select Button and then use Copy All Colors . 

. 3. Now Load Rock12 from the Progressions folder. 

4. Pull down the Options menu and change Song Size to 8 measures. 

5. Paste All Colors into measures 5 & 6, then repeat for measures 7 & 8. Measures 5 through 8 ofRockl2 are 
now the RockS progression repeated twice. 

6. Use Copy All Colors to copy measures 1 & 2, then Paste All Colors into measures 3 & 4. 

7. Now play the song and listen carefully. Although the mood and texture of the two progressions we combined 
are fairly different, all the requisite chord and scale guides are there to make an original song. 

In this etude you ' ve seen how to take a progression from one song and use it in another. You can copy and paste single or 
all colors between songs. Try making a collage with measures from your favorite arrangements. 

IX. Polyrhythm Etude 
In this etude you'll examine two examples ofpolyrhythm with Instant Music. Polyrhythm refers to two or more different 
rhythms going at once. Traditionally, polyrhythmic music is often difficult to perfonn, but by using different rhythm guides 
simultaneously in Instant Music polyrhythmic music becomes quite simple. 

1. Load Samba from the Rock2 folder. Listen to it carefully. 

2. Turn the volume for the blue and yellow tracks all the way down and put the red track at full volume. Now listen 
carefully to the main rhythm (4 beats per measure) with just the red and green tracks playing 

3. Zoom in on the frrst measure and you'll notice that there are four notes for each of the four beats in the red track. 
These are called 16th notes because with 4 notes for each quarter beat there are a total of 16 notes in a measure. 
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4. Now we'll slightly modify the rhythm. From the Draw menu, select Set Guides. Select 118 triplet from the 
Rhythm Guide column. 

5. Select the green tracl: and enter notes over the existing melody. The result should be 12 green notes in the 
measure. 

6. Listen to the result at various tempos and tum up the volume for the yellow track. You are hearing 4 beats against 
3 beats. 

7. Repeal step 5 for the remainder of the song and listen to the result 

8. Set the Rhythm Guide to 114 triplet. 

9. Eriter a new melody in the green track for the entire song. 

10. Now listen to your polyrhythmic piece. The result is heard as a 2 beat against a 3 beat rhythm. For another 
polyrhythm example, load Jazz6 from the Progressions folder and listen to it. Examine the relation between 
the green and yellow voices. This is a similar example of polyrhythm in melody. 

Used cleverly, polyrhythms can add a new level of interest to your music. However, be careful not to obscure the main beat 
with a rhythm that's too cluttered. 

If you've worked through all nine etudes, you're well on the way to becoming a seasoned musician. Butdon 't slOp here. Listen 

to the songs on the program disk and experiment with the features of Instant Music. 

CHAPTER 3: INSTANT MUSIC REFERENCE 

I. Screen Controls 
Tempo Bar - Changes the speed of the piece by moving the tempo bar to the right (faster) or left (slower). You may also 
change the tempo while a song is playing - this often results in surprising changes in mood. The tempo setting is saved with 
each song. 

Zoom Bar -Lets you zoom in 10 view a single measure, or out to view an entire song (up 10 64 measures). Every song has 
a defined maximum length (see Options Menu below), and the Zoom Bar allows you 10 zoom out to the song's defmed 
maximum length. Click the left double-arrow 10 zoom in, the right double-arrow 10 zoom out To view an entire song, make 
sure the fust measure is the leftmost measure. 

Select Bulton - Chooses notes 10 be copied, pasted, or erased. Defaults to full screen. To select a portion of the screen, 
click the mouse button at the left edge of the desired section, "drag" the area and release the button. Selections are restricted 
to measure boundaries. 

Chord Control- For selecting whether chords will be entered one, two, or three notes at a time. Position the cursor at the 
note you want to be the top note of the chord. Instant Music then aUlOmatically adds the next one or two notes (when in 2-
note or 3-note modes) below the top note according to the current chord. For example, if the chord is C7 and you are in the 
three-note mode, a lOp note of Bb will result in an E-G-Bb chord. Likewise, a top note of Fit in a 07 chord will result in a 
C-D-FIt chord. (See Scale Ruler for information on displaying chord names.) 

QuickDraw Bulton (Lightning Bolt icon) - Draws with one of the four selected patterns available in the Draw menu (see 
below). Pattern I will result in a relatively linear pattern, depending, of course, upon melody, chord, or scale mode. Pattem2 
and Pattern3 draw notes in a tremolo pattern, and Pattern4 draws notes in triplets. All in all, QuickDraw is very useful for 
inputting a large number of notes with a single broad gesture. Experimentation with QuickDraw is heartily recommended. 
Using Free Pitch Guide with the QuickDraw function produces a smooth line of notes; other pitch guides can produce wavy 
lines of notes. 

Mousejam Bulton (Mouse icon) - Allows improvisation with selected track instrument Uses Jam menu options (see 
below). 

• 
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Play/Stop Button (White or Red butlOn) - Starts and SlOpS the music. Pressing the Spacebar on the keyboard is the 
equivalent of clicking on this butlOn. 

ScroU Box and Arrows - Clicking the right arrow scrolls 1 measure 10 the right of the score window (up to the currentsong 
length). Click the left arrow to scroll 1 measure to the left of the score window (down 10 the fIrst measure). Clicking and 
dragging the scroll box moves you quickly 10 any measure or group of measures. As you drag the scroll box, measure numbers 
are shown in the Help Line at the lOp of the screen. 

You can also use the scroll box 10 make any measure the leftmost measure in the score window. Simply hold the mouse bUllon 
down inside the scroll box and drag the mouse pointer slraight down inlO the score window, then inlO the measure you would 
like on the left side of the screen. (Note the help line, Set Left Margin). Release the mouse bUllOn. This fearure only works 
if there are more measures outside of the score window 10 the right 

Track Con troIs-The trackcontroIs give you complete control over the four instrumental voices that are used in yourmusic. 
Each tracle control contains the following gadgets: 

HidelDisplay 
Button: 

Volume Bar: 

Transposition 
Buttons: 

This is a round butlOn on the right side of the track control which allows you to hide or display 
the notes for a particular tracle. This button doesn't affect sound, onl y appearance. 

This is a horizontal bar in the center of the tracle control that displays the color and controls 
the volume level of a particular track. Decrease and increase volume for a track by dragging 
the Volume Bar 10 the left or right 

These three bUllOns are located to the left of the Volume Bar on the tracle control. They lower 
or raise the octave of the selected track without changing the leey. Click the down-arrow at 
the far left to lower the octave, the up-arrow at the far right to raise.the octave, and the square 
in the center to put the track back at its normal octave. When used in the lower range of the 
score window, some instruments sound better when raised an octave with the Transposition 
BUllOns. 

To Enter Single Notes - Move the flashing cursor to the desired location and click the mouse button. When entering notes 
with guided rhythm, the time value for a given note is automatically assigned according to the rhythm guide. When in multiple 
mode and rhythm is not guided, you can click and drag the notes horizontally for longer durations up to a whole note. 

To Erase Single Notes - Move the flashing cursor to the note and Command-click. 

n. Menus and Commands 
File Menu - Use for all of Instant Music's disk and fIle commands. 

Load: Brings up the Load Dialog Box so you can load complete songs from disk, including notes, 
instruments, volume and tempo settings, and pitch and rhythm guides. 

Load New: 

Save: 

Save As: 

Quit: 

Lets you load a song template - no notes are loaded, but instruments, volume and tempo 
settings, and pitch and rhythm guides remain in place. 

Saves the loaded me 10 disk under the current me name - replaces any fIle with the sarne 
name. 

Saves the loaded me to disk under a new name -leaves original me (if any) unchanged. 

Leave the Instant Music program. 
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Edit Menu - For copying, pasting, and erasing notes; used with Select Button above the score window. 

Erase Color: 

Erase All 
Colors: 

Copy Color: 

Copy AU Colors: 

Paste Rhythm: 

Paste All 
Rhythms: 

Paste Color: 

Paste All Colors: 

Erases notes (but not rhythm guides or pitch guides) for the current IIllCk in the selected 
portion of the score window. 

Erases aU notes (but not rhythm guides or pitCh guides) in the selected portion of the score 
window. 

Copies the selected notes, rhythm guides, and pitch guides for the current track. 

Copies the selected notes, rhythm guides, and pitch guides for all four tracks. 

Inserts a copy of notes and rhythm guides (but not pitch guides) into the current track of the 
score. 

Same as Paste Rhythm, except for aU four tracks. NOTE: When pasting, select an area to 
which you are pasting exactly as you selected an area to copy. You can paste fewer measures 
than were copied, but the information will always be pasted beginning with the flrst measure 
in the copy buffer. 

InsertS copied notes, rhythm guides, and pitch guides into the current track of the score. 

Same as Paste Color, but for all four tracks. (See Note for Past e All Rhythms.) 

You can also use the copy buffer like a clipboard, enabling the insertion of a part of one song into another song. Simply copy 
the section of a song you want to move. Load the song that you want to paste the section into, then paste the section where 
desired. Check the song documentation in Appendix A to make sure that the time signature is the same for both songs, or 
notes may be lost or added. If a time signature isn't listed for a song in the Appendix A documentation, then assume that the 
time signature for that song is 4/4. 

Draw Menu - Used to select the guides for entering notes and rhythms, and also for selecting QuickDraw patterns and using 
the Scale Ruler. 

Set Guides: 
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Brings up the Set Guides Dialog Box for selecting pitch guides and rhythm guides. 

The Pitch Guide column selects the pitch guides for aU tracks. 

Melody - use a preset melody scale (the most restrictive) 
Chord - use only the notes of the current preset chord 
Scale - use only the notes of the currently-deflned scale (seven notes) 
Free - no pitch guides operating; fuD chromatic scale (12 notes) 

The Rhythm Guide column selects the rhythmic pattern for the song. 

Guided - uses the preset rhythm pattern. The rhythm guide pattern is shown in the Rhythm 
Line below the score window only when 1,2, or 3 measures are displayed. 

1/4, 1/4 triplet;-and so on - the checked rhythm operates on aU new notes entered into the 
note screen. Changing the rhythm guides determines how many beats are aUowed per 
measure, and the length of the notes you enter. 

Multiple/Discrete - If 'multiple is selected, notes of any length that are multiples of the 
selected custom rhythm are allowed; i.e., a multiple of 1/4, 1/4 triplet, and so on. If discrete 
is selected, notes of only one length are allowed. 



Scale Ruler: Brings up a set of markers on !he right side of !he screen, and a note value indicator on !he 
left side. Not operational in Free mode 

White marker line -!he root note (unison) 
Yellow marker line - dominant note (fif!h) 
Red marker line - third (mediant) or seven!h 
Green marker line - second, subdominant (fourth), and six!h 

The Scale Ruler command also brings up !he following on !he left side of !he work screen: 

Keyboard: A mini-piano, wi!h a one-octave range, showing !he keyboard equivalent of !he note under !he flashing 
cursor. 

Note: Shows !he letter name of !he note currently under !he flashing cursor. Bo!h "enharmonic" names are provided 
for sharp and flat notes. 

Number: Shows !he position of !he note relative to !he root of !he chord you are playing in. There is no number 
in Free mode. 

Rhythm Guide: Indicates which rhythmic mode you are in. This space is blank if !he rhythm is Guided, o!herwise 
a musical note is displayed showing !he current rhy!hmic unit 

Pitch Guide: M if set to Melody; S if set to Scale; C if set to Chord. There is no Pitch Guide indicator if you are 
using Free mode. 

When you use !he Scale Ruler with !he Chord or Scale Pitch Guides, !he current chord or scale name is displayed in !he Help 
Line at the top of !he screen. 

QuickDraw 
Patterns: Selects a panern wi!h which you can lay down a preset panern of notes. 

Select one of !he four patterns. Then click !he QuickDraw bunon on and draw a line in !he 
score window by clicking !he mouse bunon, dragging !he cursor, and releasing !he mouse 
button. 

Jam Menu - for using !he mouse as a realtime musical instrument 

Score Rhythm: Mousejam notes are kept wi!hin !he pitch and rhythm panern of !he currently selected track. 

Keypad Rhythm: Calls up one of nine preset jam rhy!hms by pressing a keypad number. 

Free Rhythm: Plays unguided notes using !he selected instrument wi!h each click of !he mouse bunon. 

When !he scale ruler is displayed, Mousejam response may be affected. Dose !he scale ruler if this is !he case. 

Chord jamming is one of !he many "virtuoso" tools of! nstant Music. Click !he Chord Control to jam with 2 or 3 notes at once. 
Using !he Chord ContrOl automatically activates !he Chord Pitch Guide. Instant Music on !he Apple IlGS can play 12 notes 
simultaneously, SO all four instruments can play three note chords toge!her. You can achieve a very full sound; !hough keep 
in mind that too many notes may simply lead to a cluttered sound. Songs with plenty of "open space" make great chordjam 
songs. 

Options Menu - Use this menu to set song leng!hs and empty !he copy buffer. 

Song Size: Brings up a dialog box where you can specify how many measures in length a song will be. 
Instant Music allows songs up to 64 measures long. Click !he up-arrow (+) to increase !he 
number of measures, or click !he down-arrow (-) to decrease the number of measures in a 
song. 
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Empty Burrer: Completely purges the copy buffer. Useful if you begin receiving Too Many Notes To Paste, 
or All Available Notes in Use errors. 

Sounds Menu -For loading different instruments into Instant Music. To assign an instrument to a trnck, select that trnck, 
pull down the Sounds Menu, and select the instrument you want Note: Not all combinations of instruments will be possible 
due to hardware limitations. 

Load Instrument: Brings up the Load Instrument Dialog Box so you can load an instrument into the Sounds 
menu from the Instruments folder. You can load instruments from a different disk by 
inserting that disk and clicking Disk in the dialog box until the appropriate disk name appears 
at the top. Several instruments will be loaded into the Sounds menu at one time if the files 
are organized that way; none of the files in Instant Music are organized this way, but you may 
encounter this in other programs. Instrument folders can be given any name you want, but 
it's a good idea to use Instant Music's default names since this ensures consistency as your 
data disks increase in number. 

Remove 
Instrument: Removes instruments from the Sounds Menu. When you select Remove Instrument, the 

message "Select Instrument to Remove" will appear on the Help Line. Pull down the Sounds 
Menu and select the instrument you want to remove. 

Purge Instruments: Removes all but the most recently used instruments and the default instrument To ensure 
that all of the instruments for asong load with the score, use this command to clear the Sounds 
menu of unneeded instruments before loading a song. 

III. Miscellaneous 
Drumkit - The instruments in the drumlcit appear on the screen as different octaves. You can try this out yourself using 
the scale ruler. Refer to Etude III, Drum Patterns in Chapter II. 

Default Guides - Even before you load a song into Instant Music, there are guides at work in the score window. The default 
scale guides are all "chromatic," Le., no guides. This information is important if you decide to increase the number of measures 
in an already loaded song. Though the right side of the screen is blank, these default guides are there - but invisible. Pasting 
a section of a song with guides into this area overwrites the default guides. The default rhythm guides are all whole note guides 
that serve as "place keepers" until you modify the rhythm. 

Glossary of Music Terminology 

Atonal: Lacking a traditional key or tonality. 

Chord: A group of. two or more notes played at the same time. Usually, chords consist of a pattern of successive altered or 
unaltered thirds (e.g. C7 = C-E-G-Bb; Ddim = D-F-Ab-Cb). 

Counterpoint: The interplay between two or more melodies. This often consists of a pattern of consonances ("sweet" 
sounding intervals) and dissonances ("harsh" sounding intervals), as well as implied chords. 

Diatonic Mode: An eight-note scale that may begin at any note in a major scale. When playingiust the white keys on a 
keyboard instrument, the octave (eight notes) beginning with C is known as the Ionian mode. !tis identical to the major scale. 
The octave beginning on D is the Dorian mode. Other modes include the Phrygian (E), Lydian (F), Mixolydian (G), Aeolian 
(A), and Locrian (B). Greensleeves was written in the Dorian mode. Jazz masters such as Charlie Parker, John Coltrane, and 
Cecil Taylor have exploited the possibilities of these modes in dizzying variety. 

Harmonic Voicing: When arranging a song, you may write a chord in many different ways. For instance, if you are laying 
C major chords down, you could put C (the root) on top (E-G·q, in the middle (G-C-E), or on the bottom of the chord (C
E-G). Each "voicing" has a subtle distinction within the context of a particular measure in a particular song. 

Interval: The relative spacing between two notes. For instance, the interval between C and D is a second. The interval 
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between C and E is a third, etc. 

Jam: To improvise musically with other parts or instruments, as with Mousejam. 

Key: The tonal "center" of a song; also, the tonic note (fIrst note) of a specifIc scale. 

Melody: A group of notes played sequentially (as a tune). 

Octave: The most consonant interval; the eighth tone in a major or minor scale. The interval is so consonant, that each note 
sounds like a duplication of the other. 

Polyrhythm: Multiple rhythms. This term generally refers to two or more different rhythms going on at the same time, such 
as 1/8 triplets and 1/16 notes. 

Progression: A succession of chords or harmonies. For example, a standard 12-bar blues progression is: 

C7 IC7 IC7 IC7 
F7 IF7 IC7 IC7 
G7 IF7 IC7 IC7 

Range: For a particular instrument, it is the span from the lowest note lhat can be played (well) to lhe highest note. The range 
for most instruments in Instant Music is 4-1/2 octaves; lhis entire range can be moved up or down an octave wilh lhe 
transposition buttons on lhe track controls. 

Register: An area within an instrument's range. Thecolorof an instrument often varies from register to register. Forexarnple, 
a melody played on the vibes in the low register has a much different effect from lhe same melody played in a higher register. 

Rhythm: Technically, it is the temporal pattern in which musical beats or events occur. It mig!lt also be considered as a 
"melody" independent of pitch. 

Scale: An ordered pattern of notes, usually notated in ascending or descending order. Diatonic scales, such as major and 
minor, consist of eight notes (including the octave). These are the most commonly used scales. The chromatic scale consists 
of 12 consecutive half tones (the smallest interval in Western music); the whole tone scale consists of 6 consecutive whole 
tones (e.g.: the interval from C to D or F# to G#). Other scales include the blues scale (C-D#-E-F#-G-A-Bb-C) and lhe 
diminished or octatonic scale (C-D-Eb-F-F#-G#-A-B-C). 

Transposition: Changing the key of a piece by raising it or lowering it a constant interval. In Instant Music, instrument 
transposition is done up or down one octave; thus, the key is not changed. 

APPENDIX A: INSTANT MUSIC CONCERT NOTES 

Below is documentation about all songs provided with Instant Music. The information contained here is for 
advanced users who have a working knowledge of standard music notation and chord structure. Included are the 
chord progressions for every song, as well as notes about most of the songs. Ideas are also included on how to 
improvise with this song. Some of these ideas might be thought of as "global strategies," which you can also use 
elsewhere in Instant Music. Global strategies are marked with an asterisk (0). 

SOME COMMON CHORD PROGRESSIONS 

Here are some common chords with C as the root. 

C 
Cm 
C7 
Cm7 
Cdim 
Cdim7 

C major 
C minor 
C dominant seventh 
C minor seventh 
C diminished 
C diminished seventh 

C-E-G 
C-Eb-G 
C-E-G-Bb 
C-Eb-G-Bb 
C-Eb-Gb 
C-Eb-Gb-Bb 
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The next list contains chords which are more common in jazz than in rock and roll . If you are interested in the 
spellings of 11th and 13th chords, consuH a jazz textbook. 

C07 
C7-S 
C7+S 
C9 
Cm9 
Cmaj9 
C-9 

3 C ha~ diminished 
C seven, diminished fifth 
C seven, augmented fifth 
C ninth 
C minor ninth 
C major ninth 
C diminished ninth 

C-Eb-Gb-8b 
C-E-Gb-8b 
C-E-G#-8b 
C-E-G-8b-D 
C-Eb-G-8b-D 
C-E-G-8-D 
C-E-G-8b-Db 

CHORD PROGRESSIONS USED IN INSTANT MUSIC SONGS 

ROCK1 FOLDER 
1962 Fun: This two-chord progression is perfect for composing melody after melody. 8uild your own wall of sound! 
'Try aHernating a sustained accompaniment for one or two ijerations of the tune with a rhythmic background. 

II : GIG I Em I Em :11 

Avant Rock: Asymmetric and free rhythm are exploited in this song in 5/4 rhythm. 'Try experimenting with various 
subdivisions of this meter: 

3/4 + 214 or 
214 + 3/4 or 
214 + 214 + 1/4 

Dm71Em71Am71GIFIEm 

Beau Bop: Here is a classic rock progression in a 3/4 rhythm. 'Try writing a bass solo to playoff the piano solo. 

II : C I F I G71 F :11 

C Minor Jive: Driving rhythm, pure and simple. In ourversion, sustained instruments such as organ and accordion 
are used in a percussive manner. 

CmlCmlCmlCm 
CmlCmlCmlG 
II : Cm I F I Cm I F :11 

Eighties Pop: 'Don't be shy about changing the default orchestrations of any of these songs, as they represent 
just one possibility out of many that make musical sense. 

II: C I Am I C I Am :11 
FIG I FIG 

Fifties Fantasy: A number done in the classic fifties pop song progression and style. This song is one of many 
Instant Music songs that can change drastically in mood wijh sharp shifts in tempo. 
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II: C / Am II Dm7 / G7 / :11 
C I Am II Dm7 / G7 / 
C/F/ICIII 
F I Fml C I C7 
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Frisco Vice: "Experiment wtth different instrument combinations. 

A71A71C71C7 
07 I 07 I E7 I E7 

Good aroove: Relive Woodstock wtth this one! 

C7 1F IC7 1F 
C71FIC71C7 
FIFIC7 1F 
C71FIC71C7 

Hey You: Tum this song into a 12 or 16 measure opus with the Copy and Paste commands. 

C III I Bb / F I 

Jamaican Jam: This song contains a standard reggae accompaniment. An interesting compositional technique 
to try here is a rising melody against the descending bass. Instant Bob Marleyl 

AmlAmlGIG 
F I F I E71 E7 

ROCK2 FOLDER 
Lounge Lizard: Lounge Lizard has a nifty bass pattern. 

II: C I C I C I F: :11 
Am I Am I F7 I G7 

Metallic Dream: An awesome jam song for you Twisted Sister fans. The Elecguitar stars here, but don't 
underestimate the driving, steady bass. 

AmlAmlAmlAm 
G7 I G7 I Em I Em 
OIOICIC 
Bml Bm I EI E 

Night Life: Here is one of the most rhythmic tunes in Instant Music. "Jamming with the bass is particularly effective 
in this tune. "Try using different drum parts. 

Em71 A7 I Omaj71 Bm7 
Em7 I A7 I Omaj71 Omaj7 

Night Out: This song features two drum breaks. "This is another technique for spicing up your arrangement. Just 
decide where and how long you want your solo to be, and use the copy & paste commands to shift part of your 
song by the desired number of measures. (Don't forget to shift the guides, too!) 

II: 071 071 071 C7 :11 
071071071C7 
C71C7 
II : 07 1 071 071 C7 :11 
C71C7 

Popslcle: Sure to cure the worst case of cold feet. 

II: Bb71 Bb71 Eb71 Eb71 F71 F7 :11 
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Rock Chorale: The asymmetric meter of 5/4 only serves to underscore the simplictty of the basic structure in this 
song. The two chords in this number form the basis of many great songs such as Lay/a, You Can't Always Get 
What You Want, and the chorus in You've Got to Hide Your Love Away. 

II : C I F :II 

RockIng Flight This one's sure to get you moving. 

E7 I 07 I G71 F7 I B7 I 

Samba: Written by Oan Silva (creator of DeluxePainf) . This song features a hot percussion combo. Samba's 
progression is a perfect example of the "circle of fifths"; A-O-G-C-F'-B-E . 

. Am7 I 07 I I Gmaj7 I Cmaj7 I 
F" 7 I B7 I I Em I E7 I 

Sklffle: This song illustrates the use of the skiffle rhythm, coupled with a great progression and descending bass 
line. ' Try changing the accompanying rhythm in the blue voice . 

II : C I 111 Am I111 F i l i i Om I G7 I :11 
Eml FI EmlA7 
Om7 111 1 G7 111 1 C I F I I G7 III 

JAZZ/BLUES FOLDER 
Boogie Woogle: Boogie woogie is a classic style of blues improvisation. This is one of three blues '~emplates" 
provided with Instant Music. These numbers benefit greatly from finessing parts of the solos in free mode, thus 
accessing all of the "blue" notes. 

Om I G7 I I Cmaj7 III 
F#m7 I B7 II Fm7 I Bb7 I 
Ebmaj7 I Eb71 Ebm7 I Ab7 I 
Fm7 I Bb7 I I Ebm7 II I 

Jazz Blues: An arrangement of a classic jazz blues progression. What is the red voice doing? 

Eb71 Eb7 I Eb71 Eb7 
Ab7 I Ab7 I Eb7 I Eb7 
Bb71 Ab71 Eb7 I Eb7 

Jazz Waltz: Mousejamming wtth the counter melody (Red Voice) is especially rewarding in this song. This song 
illustrates one of many variations on a blues progression, using tonic major seventh chords instead of dominant 
sevenths. 

Abmaj71 Db71 Abmaj71 Ebm71 Ab7 
Obmaj71 Dbm71 Cm71 F7-9 
Bbm7 I Eb7 I Abmaj71 Abmaj7 

Jenerlc Jazz: This song has been especially designed for 'jamming in the scale mode. 

Fmaj71 Bb7 1 Fmaj7 I Cm7 I F7+5 
Bbmaj7 I Bbm7 I Eb7 II Am71 A7-5 
G0 71 C7-9 I Fmaj7 I Abmaj7 I I Obmaj7 I C I 

Rock Blues: The 12-bar blues features a piano quartet in a rocking rhythmic arrangement. This is an excellent 
song to use the Quickdraw command. Click on the sixteenth note rhythm guide (for four notes per quarter beat) 
and enter notes in Chord mode. Now, use the lower-right Quickdraw pattern (resulting in a triplet rhythm) . A 
polyrhythmic effect results when you paste down a line. 
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FOLK FOLDER 

C7 1C7 1C7 1C7 
FYI FYI C71 C7 
G7 I FY I C7 I C7 

Barn Dance: This tune is perfect for a gradual accelerando - slowly raise the tempo bar at each verse and chorus. 
"Try duping the song and compose variations on the tune and countermelody. 

A I/I I G I Em G 
AlI l lGEmA I 

Cajun Casserole: A spicy song in the style of traditional Cajun music. 

AlAI AlA 
AIAIEIE 
E7 I E7 I E7 I E7 
E71 E71 A I A 

Rosin the Bow: A traditional folk song. 

EIEIEIA 
EIEIEIB 
EIEIG#mIA 
EIB71EIE 
EIEIAIA 
EIEIAIB 
EIEIG#mIA 
E I B71 A IE 

Sal/or's Hornpipe: Well blow me down - if it isn't the renowned Irish fiddle tune. 
II : GIGIAI D 
G I C I A I DIG :11 
GICIAID 
GIC/A/IDIG 

CLASSICAL FOLDER 
Anitra's Dance: An excerpt from the Peer Gynt Suite by Edvard Grieg (1843-1907), Anitra's Dance is styled as 
a classic mazurka - a waltz rhy1hm with a strong third beat. 

AmlAmlAmlAm 
Adim7 I Adim7 I FIB 
II : B ped I B ped :11 
EmiEmlEm/B71Em 

Bach's Joy: From the cantata Jesu, Joy of Man's Desiring by Johann Sebastian Bach (1685-1750) . 

G I Eml Am I 07 
G I Am I Am C#dim D7 I G 
G I D I C I D7 I D7 
G I Em I C 071 
G I Em I Am I D7 
G I Em I Am C#dim 07 I G I C#dim 
Dm/E71Am710m / E71Am 
Dm I E7 I Am I Am I Om I E7 
Am 
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Bourree: Many of the suHes by J.S. Bach were collections of dance music. A bourree is a French 17th-century 
dance, wHh a quick duple (two-step) meter and a single upbeat. 

Em I B7 II G 8 Em I I G 1111 B7 I Em I 
Em I B7 II G I Em I I G I 0 I I G III 
DIG II E7 I Am I E7 11 11 Am I D7 I 
G I E7 I I Am I 0 I I Bm I F#7 I I B III 
E7 I A7 I I 07 I G7 II C I F#m II B7 II E7 
Am I G I I F#m I Em II B7 11 11 Em III 

Mountain King: Another excerpt from Grieg's Peer Gynt Suite. This haunting theme was whistled by Peter Lorre 
in Fritz Lang's M. 

. II : Am I Am I Am I C :11 
II : E I E I E I E :II 

Sabre Dance: Here we have Aram Khachaturian's memorable and exciting number from the Gayne ballet. 

II: Gmaj7 -> Bb7:11 

MISCELLANEOUS FOLDER 
Greens/eeves: The well-known traditional English ballad. It is written in the Dorian mode. 

Key of G major 
Am C I G Em I Am 0 I G Em 
Am C I G Em I Am Em I Am 
C I G Em I Am 0 I Em 
C I G Em I Am Em I Am 

Frere Jacques: Here is the first ofthree rounds on Insrant Music. After a bH of experience with Instant Music, you 
will find that composing original rounds could not be easier. First, decide how many measures you want the melody 
to be and display only that number of bars on the screen. Then, compose a melody, perhaps using your own 
variation of one of the following rounds. Third, copy the color with the melody and scroll one or two measures to 
the right. Select another instrument, paste onto it, and repeat the process. If, after hearing the result , you are not 
happy with the melody, just start from the beginning. Or if you wantto be really innovative, try composing a round 
just for percussion instruments. 

La Mort de Jacques: You might think of La Mort de Jacques (also a round) as a kind of Deluxe Jacques. Fully 
orchestrated and arranged, everything is as it should be-well, almost. The key has been changed from Eb to 
Eb minor. Look at the blue voice up close - ·quick changes in octave resuH in interesting color modulations 
without changing the instrument. The methods of varying simple melodies in breathtaking ways are endless. 

Le Grand Waltz: This song is reminiscent of French pop music from the 1960's, in the style of Yves Montand and 
Michel Legrand. 

II : Am7 I 071 Gmaj71 Cmaj7 
F I Om7 I Esus4 I E :11 
AI Em I A I Em 
AIGIOIE 

Long Time Ago: An innocent song. 
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C I Am I Om7 I G7 
Cmaj7 I Am71 Om7 I G7 
F I F I Cmaj7 I C7 
F I F I G7 I Ab7 II G7 



Row, Row, Row Your Boat: Another popular round. Interesting to note is the symmetrical pattern of notes on 
the screen. How does the graphic form of the song onscreen relate to ijs aural form? 

Coming 'Round: This tradijional American song offers a perfect opportunity to sharpen one's arranging chops. 
A clear harmonic background, familiar melody and countermelody. 

FIFIFIF 
FIFICIC7 
F I F6 1 Bb I G 
CIC71FIF 

The Mlnlmal/st: This song is an example of minimalist or "new age" music, which was first nurtured in the early 
1960's by such composers as Terry Reilly and Steve Reich. It is a style of music that is particularly well suited 
to ' the ·computer. 'Experiment with different figurations (arpeggiated lines) and melodies, which oscillate 
psychologically between the background and foreground. Asymmetries abound in the 7/4 rhy1hm. Feel free to 
'experiment with various subdivisions of this meter: 

4/4 + 3/4 or 
214 + 3/4 + 214 or 
3/4 + 3/4 + 1/4 

II: F#m7 I F#m71 Gmaj7 I Gmaj7 :11 
F#m7 I F#m7 I Gmaj71 Gmaj7 
Amaj7 I Amaj7 I F#m7 I F#m7 

PROGRESSIONS FOLDER 
The following 22 chord progressions offer you the chance to explore music making under somewhat more 
controlled and focussed conditions. ' Combine your favorite arranged progressions (or even individual tracks for 
that matter) into a full-fledged song. 'Keep a folder of your own progressions, snippets, and works-in-progress. 

Rock One: C / F / IG III 

Rock Two: Om I C I I Bb II C 

Rock Three: House of the Rising Sun 

Rock Four: 

Rock Five: 

Rock Six: 

G 11/ 1 Bb /111 C 11/1 G III 

FII I IG III 

Bb 1l1 1Ab 1l1 

A IIII C III ID III I E III 

Rock Seven: Same progression used in Jamaican Jam. First used more than three centuries ago , this pro
gression was also used in So Happy Together. 

Am II I I G 11/ 1 F ili i E7 III 

Rock Eight: A very popular progression, ij formed the basis for 8aba O'Reilly. 

F II CIBb ll 1 

Rock Nine: The standard fifties progression. 

C I Am I I F I G7 I 

Rock Ten: A popular progression that is probably best known as the introduction to The Beatles' , Michel/e. 

Om I DmlC# I I DmiC I OmiB I I Bbmaj7 111 I A7 III 
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Rock Eleven: Cm I Cm7 IIAbmaj7 I G7 1 

Rock Twelve: The Beatles', Dear Prudence. 

C I C7 II Am7 I Abmaj7 I 

Rock Thirteen: G I Bm II C I D I 

Rock Fourteen: Used in Summer Loving from the movie Grease. 

O/G/IA / GI 

Jazz One: A standard progression utilizing the circle of fifths. 

Em7 1111 A7 111 1 Dm7 111 1 G7 III 

Jazz Two: Used in Day by Day. 

Fmaj7 II I Bbmaj7 II 

Jazz Three: Ebmaj7 111 1 C7 /11 1 B7 111 1 Bb7 II r 

Jazz Four: Gmaj7 I I I Bbmaj7 II I Ebmaj7 II I D7 II 

Jazz Five: Every two measures modulates down one half step. 

Jazz Six: 

Jazz Seven: 

Jazz Eight: 

Om7 I G7 II Cmaj7 III I C#m7 I F#7 I I Bmaj7 I I I 
Cm7 I F7 I IBbmaj7 III I Bm7 I E 7 I IAmaj7 III 

F#m9 III I Gmaj9 III 

Omaj 11 11 Eb'7 111 1 Em7 111 1 A7 II I 

Amaj7 III I Bbmaj7 I 

NOTICE 
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